MacOS Desktop Wallet Support


How do I re-sync my mac wallet?


With Mac there should be no sync issues.
However “never say never”, every scenario is different.

Before trying anything (new) always make sure you have a copy of the ‘keystore folder’ saved on a safe location. This folder can be found in ~/Library/Auxilium

For a fresh sync you could try:

  1. close wallet
  2. delete ‘geth’ folder from ~/Library/Auxilium
  3. restart wallet

This will let your wallet pick up all data from scratch. The blockcount will start at 0. So during the loading/syncing process your AUX balance will show 0 AUX. You can always check for the real time balance.

Sometimes the wallet gets out of sync because for instance internet connection is lost. It should pick up syncing automatically. Depending on the time being offline, internet connection, and computer specifications, this could take a while.

Always good to remember: the blockchain is where the AUX are on, the wallet is the device to manage them.


Hello Anton or anyone from AUX support. I have an issue of serious concern where I created an account and now I’m missing the account I created and over 10,000 AUX tokens. I downloaded the AUX wallet for mac around nov1st and synced up properly. I then created an account for the wallet so I would have a public address to send 10,000+ AUX to from mercatox. My tokens showed up and were sent in multiple transactions and everything seemed to be working fine until about a day ago. I checked my wallet and everything is syncing fine but it shows 0 balance and 0 accounts made with 0 transaction history. Not sure why my information would just automatically be deleted and now I have no access to my 10,000+ tokens.

This is my public AUX address. 0xd6cf61356c58b0783380f0b87d1f3bd4c8f4863a I also signed up for the air drop in time using the same address. I can check the explorer and see the transactions made from mercatox and it appears the AUX is in the wallet account address. EXPLORER info for AUX transaction from mercatox to AUX wallet.

Once again the problem is the wallet showed my balance and account just fine for days up until yesterday and now it shows 0 balance and 0 accounts created and 0 transactions. I’ve tried closing down the wallet and checked my wifi, syncing, and everything and theres no reason why I should have 0 balance. I have also read some older posts in the support section and others have had similar issues that get resolved when synced however my wallet shows that it is in fact synced properly.

At this point It really seems there might be a serious bug with the wallet automatically delete the account I created because I now don’t have access to it which is very frustrating as I was looking forward to taking part of the air drop and other benefits of holding on the AUX wallet. At this point I have no idea why this would happen or why would the wallet be set up in this way where its so easy to lose the access to tokens. Anyone help? I can also share screenshots if needed.


Sad to hear you are frustrated.

  1. 10,038.2295392500 AUX is still on the address.
  2. Most important is that you have a copy of the keystore file, like the wallet mentioned when creating the account/address. If so, no worries.
  3. A wallet reads information of the blockchain and tries to display it in the best way possible. A wallet is like any other computerprogram and should be used at own risk.
  4. There are limitless reasons why a wallet would work different for an individual, all scenarios are unique. So finding the answer might take a while.

Please check this

  1. Is the keystore file still in the correct Auxilium keystore folder (~/Library/Auxilium/Keystore)? Or did you move it instead of copying it?

  2. Once you load the wallet do you see it is connected to Peers, and updating blocks every 10 seconds?


“1. Is the keystore file still in the correct Auxilium keystore folder (~/Library/Auxilium/Keystore)? Or did you move it instead of copying it?”

Hello. I didn’t move anything or do anything after creating my only account that I used to send my AUX to.The keystore file is located in the aux folder after going to backup and checking accounts. I can see the keystore folder but nothing is inside. I didn’t remove, move, touch, or do anything so there really should be no reason my newly created account and balance just isn’t showing up.

"2. Once you load the wallet do you see it is connected to Peers, and updating blocks every 10 seconds?"
Yes. Other then the wallet not showing the account I created and showing a 0 balance the wallet is synced and peers are showing and new blocks are being received.

So the situation is I took the risk in downloading a wallet for my MAC. Since the wallet synced and was working at least at the time I then created an account as the wallet is supposed to be used and deposited AUX on it and did nothing else afterwards. The first few days my AUX tokens showed and the wallet seemed to be working just fine. Then a few days later for an unknown reason(limitless reasons) because I took my own risk in using the AUX wallet I had faith would work properly just decided to not display or allow me to have access to the tokens I just deposited even though they do show up on the address in the explorer.

So just being straight forward when I say this… There’s been other people who had similar wallet issues and past issues with the aux wallet also mostly on windows I read about on this forum. Seems most people were able to get back their access to their tokens eventually. Now for another unknown reason which could be limitless reasons as it all comes with the risk of using a supposedly secure wallet off the exchange which is recommended I am now out over 10,000 AUX because I took the risk in supporting and using the AUX wallet? Maybe I didn’t provide enough information or am missing something?

Just trying to be thorough enough and figure out the next best steps as I was looking forward to supporting your project, using the aux wallet, sharing it around with others I know, and adding more to my wallet.
Or basically to make a long story short is there just no way to get my tokens back which could be because a number of unknown reasons and the AUX wallet comes with far too many risks at this point? Thank you.


I understand you would like to have your 10.000 AUX coins back. The 10K AUX is still on the address.

Using the wallet is at own risk, like stated in the terms and services document on the website. But this does not mean we do not want to help you resolve your problem. We always try to help everyone as good as possible through this support forum.

I have to say it is very unlikely the wallet deleted the keystore file itself.

The wallet is safe to keep your AUX on and transfer AUX with. I personally use the desktop wallet for AUX. I use both the windows and mac, and I am confident my AUX are safe at all times.

You keystore file is the same as your account. If your keystore file is not in the keystore folder it means your account will not show in your wallet. If you lose your keystore file you lose control/access over your account.

It is therefore very important to make back-ups of your keystore file(s), like mentioned when creating the account. After account creation in the wallet there is a warning/note you should back-up your keystore. If you have a back-up of your keystore file (which is your account) you can simply copy+paste the keystore file back into the keystore folder.

Did you create a back-up of the keystore-file?


Guess I might be screwed but I thought the wallet backed up itself when a new account/address is created as I was told in the telegram. I was told this by a few people and I think you also that once an account is made the wallet automatically backs it up. So maybe I’m missing something here. Also the aux wallet is very different than most standard desktop wallets I’ve used. I’ve still managed many different desktop wallets in the past and still do and make sure to have my private keys and info backed up however this is the first that the wallet completely just made me lose access to my account or address even if I didn’t make a back up(not sure if it made one or not)… I guess I assumed everything in the wallet was working fine as I was able to deposit more tokens to the address and see them securely arrive. Only later on to check the wallet again a couple days later only to see a 0 balance and 0 accounts/addresses and 0 transaction history for some unknown reason.

I guess I would think there would be a way I could see my private info on the wallet in order to have access to my tokens that were deposited on that wallet which would be a much safer option than trusting a keystore or having faith the wallet will not have any unknown issues as you stated it is a risk… I think there’s just too many variables that could make something go wrong possibly. So in my opinion it seems more of a faulty design rather than user error but of course thats my personal opinion from experience. Probably due to the fact its never a good feeling and very disappointing losing tokens of a project I’m excited about supporting and taking a position on. I guess I shouldn’t be surprised I’m now basically gonna be SOL.

I think it has to do with the fact the AUX wallet is designed for the user to create “accounts” instead of just having an automatic address that doesn’t have the risk of just vanishing. It just seems much easier to print out or screenshot a privatekey based on the address easily which is what I normally would do. I believe this is what adds some risk to using this type of wallet personally but I am of course basing this of my own personal experience.

So still not completely sure why I lost access to my tokens and or why the wallet would be set up that way.


Every wallet is different. Some wallets have a recovery code, some wallets have a recovery file. Auxilium has a recovery file, the keystore file, just like Ethereum for instance.

I understand the disappointment, however you are responsible for making a back-up. That would have solved this issue you are having now. Not backing up a recovery code or phrase within a different wallet would have resulted in the same problem.

When creating an account the wallet gives a pop-up to be sure to back-up the keystore file. You then clicked “OK” to continue, but did not follow this advise to backup the keystore file unfortunately.


Just thinking out loud…
You might be able to find the keystore file by searching your Mac with your AUX-address (the AUX-address is within the title of the keystore file)? It might be in a different location?
Or restore your device to a previous date?

Once an account is created the keystore file is created. If the keystore file is removed for some reason it should be somewhere in the bin (with removed files), or should be visible in the past.

Once you lose your keystore file you lose control/access over your account and the AUX coins on it.

I appreciate you choosing to support Auxilium, but can’t make the story any more positive unfortunately. Hope you find your keyfile.


Hello again. So it appears I do have an AUX keystore folder that was saved on nov 1st titled AUX Keystore. I would share screenshots in here but don’t see the option. It does appear to have the last part of the missing account/address with the 10,000 aux tokens in the title. I think the AUX Keystore folder was when I created the account address. There is another folder to the right of it simply titled keystore that is empty. Not sure why there would be two.

At this point not sure what to do with the keystore folder. I would have assumed it would work within the wallet as the other folders are all together in the same AUX folder location with geth folders. What would be the process to see if I can recover my account?


It would be great if you have the keyfile, it sounds like you have.

What you want is keystore folder with keyfile (with account number) in it. Not a folder in a folder.

If you have everything in the right place the wallet will find the account and will show the balance.

Printscreens can be posted by using copy + paste in textbox or inserting an image by clicking the upload icon in text editor.


Hi @Stackingcryptos,

Have you sorted out your missing address already? If not, send Anton more information so that he can help you resolve this issue quickly.

We’d like to know you’ve managed to recover your missing coins (they’re coins, not tokens :smile: )

I’m about to go off-line but Anton will assist when he’s sitting at his PC next.



Hello. I’ve been working and haven’t had time to try to fix the wallet. Not sure what to do at this point but i can see what appears to be the keystore file. Still no AUX in balance and the account is gone from the wallet. I’ll have more time later tonight and this weekend to see if I can still access my AUX so any suggestions are welcomed. Thank you James.


If you have found the keyfile @Stackingcryptos you have your AUX for sure. Would be fantastic if you have.

The actual file might be misplaced by accident resulting in the wallet not finding the file and not being able to retrieve the balance.

Please send me a pm with a printscreen of:

  • the file you think is the keyfile
  • ~/Library/Auxilium
  • ~/Library/Auxilium/Keystore


Issue solved! :ballot_box_with_check:
Keyfile was not in correct keystore folder.


So the @Stackingcryptos managed to solve the problem, that good, in the forum is much easier to provide the support.


Yes, issue solved. Within the forum we can provide our community with the best support possible. :slightly_smiling_face:


Thanks for all the support guys. Apologies for freaking out about it was just scared I lost my AUX lol.
Luckily I still had the keystore file just wasn’t in the correct spot. Anyway thanks for everyones patience and helping me out with this issue as I know I was pretty stressed out and frustrated. Not sure how it happened or was moved in the first place but so happy it seems to be working again. Maybe this will help if anyone else runs into the same issue. Looking forward to adding more AUX to my stack and watching the progress of the project. :slight_smile:



Update about the network maintenance: Roadmap and updates (updated daily)
Hope you all have a good day!